procps-ng vulnerabilities

2018-06-05T00:00:00
ID USN-3658-2
Type ubuntu
Reporter Ubuntu
Modified 2018-06-05T00:00:00

Description

USN-3658-1 fixed a vulnerability in procps-ng. This update provides the corresponding update for Ubuntu 12.04 ESM.

Original advisory details:

It was discovered that libprocps incorrectly handled the file2strvec() function. A local attacker could possibly use this to execute arbitrary code. (CVE-2018-1124)

It was discovered that procps-ng incorrectly handled memory. A local attacker could use this issue to cause a denial of service, or possibly execute arbitrary code. (CVE-2018-1126)