logo
DATABASE RESOURCES PRICING ABOUT US

OpenSSH vulnerabilities

Description

Jann Horn discovered that OpenSSH incorrectly loaded PKCS#11 modules from untrusted directories. A remote attacker could possibly use this issue to execute arbitrary PKCS#11 modules. This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. (CVE-2016-10009) Jann Horn discovered that OpenSSH incorrectly handled permissions on Unix-domain sockets when privilege separation is disabled. A local attacker could possibly use this issue to gain privileges. This issue only affected Ubuntu 16.04 LTS. (CVE-2016-10010) Jann Horn discovered that OpenSSH incorrectly handled certain buffer memory operations. A local attacker could possibly use this issue to obtain sensitive information. This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. (CVE-2016-10011) Guido Vranken discovered that OpenSSH incorrectly handled certain shared memory manager operations. A local attacker could possibly use issue to gain privileges. This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. (CVE-2016-10012) Michal Zalewski discovered that OpenSSH incorrectly prevented write operations in readonly mode. A remote attacker could possibly use this issue to create zero-length files, leading to a denial of service. (CVE-2017-15906)


Affected Package


OS OS Version Package Name Package Version
Ubuntu 17.10 openssh-server 1:7.5p1-10ubuntu0.1
Ubuntu 16.04 openssh-server 1:7.2p2-4ubuntu2.4
Ubuntu 16.04 openssh-client 1:7.2p2-4ubuntu2.4
Ubuntu 16.04 openssh-client-dbgsym 1:7.2p2-4ubuntu2.4
Ubuntu 16.04 openssh-client-ssh1 1:7.2p2-4ubuntu2.4
Ubuntu 16.04 openssh-client-ssh1-dbgsym 1:7.2p2-4ubuntu2.4
Ubuntu 16.04 openssh-client-udeb 1:7.2p2-4ubuntu2.4
Ubuntu 16.04 openssh-client-udeb-dbgsym 1:7.2p2-4ubuntu2.4
Ubuntu 16.04 openssh-server-dbgsym 1:7.2p2-4ubuntu2.4
Ubuntu 16.04 openssh-server-udeb 1:7.2p2-4ubuntu2.4
Ubuntu 16.04 openssh-server-udeb-dbgsym 1:7.2p2-4ubuntu2.4
Ubuntu 16.04 openssh-sftp-server 1:7.2p2-4ubuntu2.4
Ubuntu 16.04 openssh-sftp-server-dbgsym 1:7.2p2-4ubuntu2.4
Ubuntu 16.04 ssh 1:7.2p2-4ubuntu2.4
Ubuntu 16.04 ssh-askpass-gnome 1:7.2p2-4ubuntu2.4
Ubuntu 16.04 ssh-askpass-gnome-dbgsym 1:7.2p2-4ubuntu2.4
Ubuntu 16.04 ssh-krb5 1:7.2p2-4ubuntu2.4
Ubuntu 14.04 openssh-server 1:6.6p1-2ubuntu2.10
Ubuntu 14.04 openssh-client 1:6.6p1-2ubuntu2.10
Ubuntu 14.04 openssh-client-udeb 1:6.6p1-2ubuntu2.10
Ubuntu 14.04 openssh-server-udeb 1:6.6p1-2ubuntu2.10
Ubuntu 14.04 openssh-sftp-server 1:6.6p1-2ubuntu2.10
Ubuntu 14.04 ssh 1:6.6p1-2ubuntu2.10
Ubuntu 14.04 ssh-askpass-gnome 1:6.6p1-2ubuntu2.10
Ubuntu 14.04 ssh-krb5 1:6.6p1-2ubuntu2.10

Related