Lucene search

K
ubuntuUbuntuUSN-3337-1
HistoryJun 21, 2017 - 12:00 a.m.

Valgrind vulnerabilities

2017-06-2100:00:00
ubuntu.com
41

6.8 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:P/A:P

7.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

6.3 Medium

AI Score

Confidence

High

0.026 Low

EPSS

Percentile

90.3%

Releases

  • Ubuntu 17.04
  • Ubuntu 16.10
  • Ubuntu 16.04 ESM
  • Ubuntu 14.04 ESM

Packages

  • valgrind - instrumentation framework for building dynamic analysis tools

Details

It was discovered that Valgrind incorrectly handled certain string
operations. If a user or automated system were tricked into processing a
specially crafted binary, a remote attacker could possibly execute
arbitrary code. This issue only affected Ubuntu 14.04 LTS, Ubuntu 16.04
LTS and Ubuntu 16.10. (CVE-2016-2226)

It was discovered that Valgrind incorrectly handled parsing certain
binaries. If a user or automated system were tricked into processing a
specially crafted binary, a remote attacker could use this issue to cause
Valgrind to crash, resulting in a denial of service. (CVE-2016-4487,
CVE-2016-4488, CVE-2016-4489, CVE-2016-4490, CVE-2016-4491, CVE-2016-4492,
CVE-2016-4493, CVE-2016-6131)

OSVersionArchitecturePackageVersionFilename
Ubuntu17.04noarchvalgrind< 1:3.12.0-1ubuntu1.1UNKNOWN
Ubuntu17.04noarchvalgrind-dbg< 1:3.12.0-1ubuntu1.1UNKNOWN
Ubuntu17.04noarchvalgrind-dbgsym< 1:3.12.0-1ubuntu1.1UNKNOWN
Ubuntu17.04noarchvalgrind-mpi< 1:3.12.0-1ubuntu1.1UNKNOWN
Ubuntu17.04noarchvalgrind-mpi-dbgsym< 1:3.12.0-1ubuntu1.1UNKNOWN
Ubuntu16.10noarchvalgrind< 1:3.12.0~svn20160714-1ubuntu2.1UNKNOWN
Ubuntu16.10noarchvalgrind-dbg< 1:3.12.0~svn20160714-1ubuntu2.1UNKNOWN
Ubuntu16.10noarchvalgrind-dbgsym< 1:3.12.0~svn20160714-1ubuntu2.1UNKNOWN
Ubuntu16.10noarchvalgrind-mpi< 1:3.12.0~svn20160714-1ubuntu2.1UNKNOWN
Ubuntu16.10noarchvalgrind-mpi-dbgsym< 1:3.12.0~svn20160714-1ubuntu2.1UNKNOWN
Rows per page:
1-10 of 161

6.8 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:P/A:P

7.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

6.3 Medium

AI Score

Confidence

High

0.026 Low

EPSS

Percentile

90.3%