logo
DATABASE RESOURCES PRICING ABOUT US

libxml2 vulnerabilities

Description

## Releases * Ubuntu 15.10 * Ubuntu 15.04 * Ubuntu 14.04 ESM * Ubuntu 12.04 ## Packages * libxml2 \- GNOME XML library Kostya Serebryany discovered that libxml2 incorrectly handled certain malformed documents. If a user or automated system were tricked into opening a specially crafted document, an attacker could possibly cause libxml2 to crash, resulting in a denial of service. (CVE-2015-5312, CVE-2015-7497, CVE-2015-7498, CVE-2015-7499,CVE-2015-7500) Hugh Davenport discovered that libxml2 incorrectly handled certain malformed documents. If a user or automated system were tricked into opening a specially crafted document, an attacker could possibly cause libxml2 to crash, resulting in a denial of service. (CVE-2015-8241, CVE-2015-8242) Hanno Boeck discovered that libxml2 incorrectly handled certain malformed documents. If a user or automated system were tricked into opening a specially crafted document, an attacker could possibly cause libxml2 to crash, resulting in a denial of service. This issue only applied to Ubuntu 12.04 LTS, Ubuntu 14.04 LTS and Ubuntu 15.04. (CVE-2015-8317)


Affected Package


OS OS Version Package Name Package Version
Ubuntu 15.10 libxml2 2.9.2+zdfsg1-4ubuntu0.2
Ubuntu 15.04 libxml2 2.9.2+dfsg1-3ubuntu0.2
Ubuntu 14.04 libxml2 2.9.1+dfsg1-3ubuntu4.6
Ubuntu 14.04 libxml2-dbg 2.9.1+dfsg1-3ubuntu4.6
Ubuntu 14.04 libxml2-dev 2.9.1+dfsg1-3ubuntu4.6
Ubuntu 14.04 libxml2-doc 2.9.1+dfsg1-3ubuntu4.6
Ubuntu 14.04 libxml2-udeb 2.9.1+dfsg1-3ubuntu4.6
Ubuntu 14.04 libxml2-utils 2.9.1+dfsg1-3ubuntu4.6
Ubuntu 14.04 libxml2-utils-dbg 2.9.1+dfsg1-3ubuntu4.6
Ubuntu 14.04 python-libxml2 2.9.1+dfsg1-3ubuntu4.6
Ubuntu 14.04 python-libxml2-dbg 2.9.1+dfsg1-3ubuntu4.6
Ubuntu 12.04 libxml2 2.7.8.dfsg-5.1ubuntu4.13

Related