Quagga vulnerabilities

2011-03-29T00:00:00
ID USN-1095-1
Type ubuntu
Reporter Ubuntu
Modified 2011-03-29T00:00:00

Description

It was discovered that Quagga incorrectly parsed certain malformed extended
communities. A remote attacker could use this flaw to cause Quagga to
crash, resulting in a denial of service. (CVE-2010-1674)

It was discovered that Quagga resets BGP sessions when encountering
malformed AS_PATHLIMIT attributes. A remote attacker could use this flaw to
disrupt BGP sessions, resulting in a denial of service. This update removes
AS_PATHLIMIT support from Quagga. This issue only affected Ubuntu 8.04 LTS,
9.10, 10.04 LTS and 10.10. (CVE-2010-1675)