It has been discovered that the extension phpMyAdmin (phpmyadmin) is vulnerable to Cross-Site Scripting.
Component Type: Third party extension. This extension is not a part of the TYPO3 default installation.
Affected Versions: Version 4.8.1 and below
Vulnerability Type: Cross-Site Scripting
References: CVE-2010-3056, PMASA-2010-5
Release Date: 23.08.2010
Problem Description: Some URLs in phpMyAdmin do not properly escape user inputs that lead to cross site scripting vulnerabilities.
Solution: An updated version 4.9.0 is available from the TYPO3 extension manager and at typo3.org/extensions/repository/view/phpmyadmin/4.9.0/. Users of the extension are advised to update the extension as soon as possible.
The TYPO3 Security Team requests TYPO3 administrators to consider our advice from TYPO3-SA-2009-015 to either use extension phpMyAdmin only on development servers or to use the phpMyAdmin standalone application on production servers.
General advice: Follow the recommendations that are given in the TYPO3 Security Cookbook. Please subscribe to the typo3-announce mailing list to receive future Security Bulletins via E-mail.
Credits: The vendor of the standalone product credits Aung Khant.