Cross-Site Scripting vulnerability in extension Commerce (commerce)

2009-08-18T00:00:00
ID TYPO3-SA-2009-011
Type typo3
Reporter TYPO3 Association
Modified 2009-08-18T00:00:00

Description

It has been discovered that the extension Commerce (commerce) is vulnerable to Cross-Site Scripting attacks.

Release Date: August 18, 2009

Component Type: Third party extension. This extension is not part of the TYPO3 default installation.

Affected Versions: Version 0.9.8 and below.

Vulnerability Type: (Persistent) Cross-Site Scripting (XSS)

Severity: Medium

Problem Description: Failing to properly sanitize user-supplied input the extension is open to Cross-Site Scripting attacks. A customer, who has appropriate rights to order products, is able to inject JavaScript code that gets executed in the TYPO3 backend (administration interface).

Solution: After you have retrieved a current list of available plugins from the TYPO3 Extension Repository, Commerce version 0.9.9 is available from the TYPO3 extension manager. Alternatively, you can manually download the T3X file containing the security update from http://typo3.org/extensions/repository/view/commerce/0.9.9/.

In case you are using a DEV version from the Subversion repository of Commerce, please sync to revision 23434 or higher (trunk). There is also a branch (0.9.x) available for Commerce version 0.9.x which contains the security fix as of revision 24333.

General advice: Follow the recommendations that are given in the TYPO3 Security Cookbook. Please subscribe to the typo3-announce mailing list to receive future Security Bulletins via E-mail.

Credits: Credits go to Fabian Friedrich who discovered the issue. Furthermore the TYPO3 Security Team wishes to thank the Commerce team for fixing this issue.