Multiple SQL Injection vulnerabilities in extension "Website Photo Gallery" (jm_gallery)

2011-08-03T00:00:00
ID TYPO3-EXT-SA-2011-002
Type typo3
Reporter TYPO3 Association
Modified 2011-08-03T00:00:00

Description

It has been discovered that the extension Website Photo Gallery (jm_gallery) is vulnerable to SQL injection.

Component Type: Third party extension. This extension is not a part of the TYPO3 default installation.

Affected Versions: Version 0.9.1 and below

Vulnerability Type: SQL Injection

Severity: High

Suggested CVSS v2.0: AV:N/AC:L/Au:N/C:C/I:C/A:P/E:H/RL:OF/RC:C (What's that?)

Release Date: 03.08.2011

Problem Description: Failing to sanitize GET/ POST data, the extension is susceptible to multiple SQL Injection vulnerabilities.

Solution: An updated version 0.9.2 is available from the TYPO3 extension manager and attypo3.org/extensions/repository/view/jm_gallery/0.9.2/. Users of the extension are advised to update the extension immediately.

Important Note: It has been reported to the TYPO3 Security Team that this vulnerability has been exploited in the wild.

Credits: Thanks to Ivan Kartolo who discovered and reported the issue and especially for providing a fixed version of the extension.

General advice: Follow the recommendations that are given in the TYPO3 Security Cookbook. Please subscribe to thetypo3-announce mailing list to receive future Security Bulletins via E-mail.