logo
DATABASE RESOURCES PRICING ABOUT US

Microsoft SharePoint CVE-2012-1863 Cross Site Scripting Vulnerability

Description

### Description Microsoft SharePoint is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input. An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to perform unauthorized actions such as reading, modifying, or deleting content on behalf of the victim on the SharePoint site. ### Technologies Affected * Microsoft InfoPath 2007 * Microsoft InfoPath 2007 SP2 * Microsoft InfoPath 2007 SP3 * Microsoft InfoPath 2010 (32-bit editions) * Microsoft InfoPath 2010 (64-bit editions) * Microsoft InfoPath 2010 * Microsoft InfoPath 2010 SP1 (32-bit editions) * Microsoft InfoPath 2010 SP1 (64-bit editions) * Microsoft Office SharePoint Server 2007 SP2 (64-bit) * Microsoft Office SharePoint Server 2007 SP2 * Microsoft Office SharePoint Server 2007 SP3 (64-bit) * Microsoft Office SharePoint Server 2007 SP3 * Microsoft SharePoint Foundation 2010 * Microsoft SharePoint Foundation 2010 SP1 ### Recommendations **Run all software as a nonprivileged user with minimal access rights.** Attackers may successfully exploit client flaws in the browser through cross-site scripting vulnerabilities. When possible, run client software as regular user accounts with limited access to system resources. This may limit the immediate consequences of client-side vulnerabilities. **Deploy network intrusion detection systems to monitor network traffic for malicious activity.** Deploy NIDS to detect and block attacks and anomalous activity such as requests containing suspicious URI sequences. Since the webserver may log such requests, review its logs regularly. **Do not follow links provided by unknown or untrusted sources.** Web users should be cautious about following links to websites that are provided by unfamiliar or suspicious sources. Filtering HTML from emails may help remove a possible vector for transmitting malicious links to users. **Set web browser security to disable the execution of script code or active content.** Since exploiting cross-site scripting issues often requires malicious script code to run in browsers, consider disabling script code and active content support within a client browser as a way to prevent a successful exploit. Note that this mitigation tactic might adversely affect legitimate sites that rely on the execution of browser-based script code. Vendor updates are available. Please see the references for more information.


Affected Software


CPE Name Name Version
microsoft infopath 2010 SP1 (64-bit editions)
microsoft infopath 2007
microsoft office sharepoint server 2007 SP3 (64-bit)
microsoft office sharepoint server 2007 SP2 (64-bit)
microsoft infopath 2010
microsoft infopath 2007 SP2
microsoft infopath 2007 SP3
microsoft infopath 2010 SP1 (32-bit editions)
microsoft sharepoint foundation 2010
microsoft office sharepoint server 2007 SP2
microsoft infopath 2010 (64-bit editions)
microsoft sharepoint foundation 2010 SP1
microsoft office sharepoint server 2007 SP3
microsoft infopath 2010 (32-bit editions)

Related