Apple Mac OS X Archive Metadata Command Execution Vulnerability

2006-02-21T00:00:00
ID SMNTC-16736
Type symantec
Reporter Symantec Security Response
Modified 2006-02-21T00:00:00

Description

Description

Apple Mac OS X is prone to an arbitrary command-execution vulnerability when processing metadata in archive files. Commands would be executed in the context of the user opening the archive file. Attackers can reportedly use Safari and Apple Mail as exploitation vectors for this vulnerability. Mac OS X 10.4.5 is reported to be vulnerable. Earlier versions may also be affected.

Technologies Affected

  • Apple Mac OS X 10.3.9
  • Apple Mac OS X 10.4.5
  • Apple Mac OS X Server 10.3.9
  • Apple Mac OS X Server 10.4.5

Recommendations

Do not accept or execute files from untrusted or unknown sources.
Do not open files that originate from unknown or untrusted sources, even those considered to be of a safe file type. This will mitigate against this and other latent vulnerabilities.

Run all software as a nonprivileged user with minimal access rights.
Always perform daily tasks as an unprivileged user with minimal access rights. This will limit the consequences of successful exploitation of this and other latent vulnerabilities.

Apple has released security advisory APPLE-SA-2006-03-01 to address this issue. Apple has also released security advisory APPLE-SA-2006-03-13 with further updates to address this issue.