Microsoft Internet Explorer Unspecified ActiveX Image Control Vulnerability

2005-02-08T00:00:00
ID SMNTC-12477
Type symantec
Reporter Symantec Security Response
Modified 2005-02-08T00:00:00

Description

Description

Microsoft has announced in the MS05-014 Cumulative Internet Explorer bulletin that the ActiveX Image Control 1.0 is no longer supported due to an unspecified security vulnerability. The cumulative update addresses the vulnerability by setting the kill-bit on the control so that it may no longer be invoked from Internet Explorer. The impact of this unspecified vulnerability is not known at this time.

Technologies Affected

  • Microsoft Internet Explorer 5.0.1
  • Microsoft Internet Explorer 5.0.1 SP1
  • Microsoft Internet Explorer 5.0.1 SP2
  • Microsoft Internet Explorer 5.0.1 SP3
  • Microsoft Internet Explorer 5.0.1 SP4
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5 SP1
  • Microsoft Internet Explorer 5.5 SP2
  • Microsoft Internet Explorer 6.0
  • Microsoft Internet Explorer 6.0 SP1
  • Microsoft Internet Explorer 6.0 SP2 do not use
  • Nortel Networks IP softphone 2050
  • Nortel Networks Mobile Voice Client 2050
  • Nortel Networks Optivity Telephony Manager (OTM)
  • Nortel Networks Symposium Web Center Portal (SWCP)
  • Nortel Networks Symposium Web Client

Recommendations

Run all software as a nonprivileged user with minimal access rights.
Perform all non-administrative tasks, such as browsing the Web and reading e-mail, as an unprivileged user with minimal access rights. This will limit the consequences of successful exploitation.

Do not follow links provided by unknown or untrusted sources.
Web users should be wary of visiting links provided by untrusted or unfamiliar sources since this issue may be exploited by a malicious Web page.

Set web browser security to disable the execution of script code or active content.
Disable support for client-side scripting and active content in the Internet Zone. The vulnerable DHTML methods require client-side scripting to be invoked.

Microsoft has released a cumulative update for Internet Explorer to address this and other vulnerabilities. Updates for Internet Explorer on Microsoft Windows 98/98SE/ME may be obtained through Windows Update. Nortel Networks has released security advisory 2005005511-2 acknowledging this issue. Please the referenced advisory for further information.