PHP CVE-2019-11045 Multiple Unspecified Security Vulnerabilities

2019-12-18T00:00:00
ID SMNTC-111314
Type symantec
Reporter Symantec Security Response
Modified 2019-12-18T00:00:00

Description

Description

PHP is prone to multiple unspecified security vulnerabilities. An attacker can exploit these issues to perform certain unauthorized actions and gain access to the affected application. Other attacks are also possible. PHP 7.2.0 through 7.2.26, 7.3.0 through 7.3.12 and 7.4.0 are vulnerable.

Technologies Affected

  • PHP PHP 7.2.0
  • PHP PHP 7.2.1
  • PHP PHP 7.2.12
  • PHP PHP 7.2.13
  • PHP PHP 7.2.14
  • PHP PHP 7.2.16
  • PHP PHP 7.2.17
  • PHP PHP 7.2.18
  • PHP PHP 7.2.19
  • PHP PHP 7.2.2
  • PHP PHP 7.2.25
  • PHP PHP 7.2.3
  • PHP PHP 7.2.4
  • PHP PHP 7.2.5
  • PHP PHP 7.2.6
  • PHP PHP 7.2.7
  • PHP PHP 7.2.8
  • PHP PHP 7.3.0
  • PHP PHP 7.3.1
  • PHP PHP 7.3.10
  • PHP PHP 7.3.11
  • PHP PHP 7.3.12
  • PHP PHP 7.3.2
  • PHP PHP 7.3.3
  • PHP PHP 7.3.4
  • PHP PHP 7.3.5
  • PHP PHP 7.3.6
  • PHP PHP 7.3.7
  • PHP PHP 7.3.8
  • PHP PHP 7.3.9
  • PHP PHP 7.4.0

Recommendations

Block external access at the network boundary, unless external parties require service.
If global access isn't needed, filter access to the affected computer at the network boundary. Restricting access to only trusted computers and networks might greatly reduce the likelihood of successful exploits.

Block external access at the network boundary, unless external parties require service.
If global access isn't needed, filter access to the affected computer at the network boundary. Restricting access to only trusted computers and networks might greatly reduce the likelihood of successful exploits.

Deploy network intrusion detection systems to monitor network traffic for malicious activity.
Deploy NIDS to monitor network traffic for signs of anomalous or suspicious activity. This includes but is not limited to requests that include NOP sleds and unexplained incoming and outgoing traffic. This may indicate exploit attempts or activity that results from a successful exploit.

Updates are available. Please see the references or vendor advisory for more information.