Adobe ColdFusion CVE-2019-8256 Remote Privilege Escalation Vulnerability

2019-12-10T00:00:00
ID SMNTC-111139
Type symantec
Reporter Symantec Security Response
Modified 2019-12-10T00:00:00

Description

Description

Adobe ColdFusion is prone to a remote privilege-escalation vulnerability. An attacker may exploit this issue to gain elevated privileges. Successful exploits may aid in further attacks.

Technologies Affected

  • Adobe ColdFusion 10
  • Adobe ColdFusion 10 Update 1
  • Adobe ColdFusion 10 Update 10
  • Adobe ColdFusion 10 Update 11
  • Adobe ColdFusion 10 Update 12
  • Adobe ColdFusion 10 Update 13
  • Adobe ColdFusion 10 Update 15
  • Adobe ColdFusion 10 Update 16
  • Adobe ColdFusion 10 Update 17
  • Adobe ColdFusion 10 Update 18
  • Adobe ColdFusion 10 Update 19
  • Adobe ColdFusion 10 Update 20
  • Adobe ColdFusion 10 Update 21
  • Adobe ColdFusion 10 Update 22
  • Adobe ColdFusion 10 Update 23
  • Adobe ColdFusion 10 Update 5
  • Adobe ColdFusion 10 Update 6
  • Adobe ColdFusion 10 Update 9
  • Adobe ColdFusion 10.0
  • Adobe ColdFusion 10.0 Update 1
  • Adobe ColdFusion 10.0 Update 11
  • Adobe ColdFusion 10.0 Update 14
  • Adobe ColdFusion 10.0 Update 2
  • Adobe ColdFusion 10.0 Update 3
  • Adobe ColdFusion 10.0 Update 4
  • Adobe ColdFusion 10.0 Update 8
  • Adobe ColdFusion 10.0.0
  • Adobe ColdFusion 10.0.1
  • Adobe ColdFusion 10.0.2
  • Adobe ColdFusion 10.0.3
  • Adobe ColdFusion 10.0.4
  • Adobe ColdFusion 10.0.5
  • Adobe ColdFusion 11
  • Adobe ColdFusion 11 Update 1
  • Adobe ColdFusion 11 Update 10
  • Adobe ColdFusion 11 Update 11
  • Adobe ColdFusion 11 Update 12
  • Adobe ColdFusion 11 Update 13
  • Adobe ColdFusion 11 Update 14
  • Adobe ColdFusion 11 Update 15
  • Adobe ColdFusion 11 Update 16
  • Adobe ColdFusion 11 Update 17
  • Adobe ColdFusion 11 Update 18
  • Adobe ColdFusion 11 Update 19
  • Adobe ColdFusion 11 Update 3
  • Adobe ColdFusion 11 Update 4
  • Adobe ColdFusion 11 Update 5
  • Adobe ColdFusion 11 Update 6
  • Adobe ColdFusion 11 Update 7
  • Adobe ColdFusion 11 Update 8
  • Adobe ColdFusion 11 Update 9
  • Adobe ColdFusion 11.0 Update 2
  • Adobe ColdFusion 2016.0.0
  • Adobe ColdFusion 2016.0.0 Update 1
  • Adobe ColdFusion 2016.0.0 Update 10
  • Adobe ColdFusion 2016.0.0 Update 11
  • Adobe ColdFusion 2016.0.0 Update 12
  • Adobe ColdFusion 2016.0.0 Update 2
  • Adobe ColdFusion 2016.0.0 Update 3
  • Adobe ColdFusion 2016.0.0 Update 4
  • Adobe ColdFusion 2016.0.0 Update 5
  • Adobe ColdFusion 2016.0.0 Update 6
  • Adobe ColdFusion 2016.0.0 Update 7
  • Adobe ColdFusion 2016.0.0 Update 8
  • Adobe ColdFusion 2016.0.0 Update 9
  • Adobe ColdFusion 2018.0.0 Update 1
  • Adobe ColdFusion 2018.0.0 Update 2
  • Adobe ColdFusion 2018.0.0 Update 3
  • Adobe ColdFusion 2018.0.0 Update 4
  • Adobe ColdFusion 2018.0.0 Update 5
  • Adobe ColdFusion 2018.0.0 Update 6

Recommendations

Run all software as a nonprivileged user with minimal access rights.
To reduce the impact of latent vulnerabilities, always run nonadministrative software as an unprivileged user with minimal access rights.

Deploy network intrusion detection systems to monitor network traffic for malicious activity.
Deploy NIDS to monitor network traffic for signs of suspicious or anomalous activity. This may help detect malicious actions that an attacker may take after successfully exploiting vulnerabilities in applications. Review all applicable logs regularly.

Do not accept or execute files from untrusted or unknown sources.
To reduce the likelihood of successful exploits, never handle files that originate from unfamiliar or untrusted sources.

Do not follow links provided by unknown or untrusted sources.
Web users should be cautious about following links to sites that are provided by unfamiliar or suspicious sources. Filtering HTML from emails may help remove a possible vector for transmitting malicious links to users.

Updates are available. Please see the references or vendor advisory for more information.