Wireshark CVE-2019-19553 Denial of Service Vulnerability

2019-12-04T00:00:00
ID SMNTC-111100
Type symantec
Reporter Symantec Security Response
Modified 2019-12-04T00:00:00

Description

Description

Wireshark is prone to a remote denial-of-service vulnerability because it fails to properly handle certain type of packets. An attacker can leverage this issue to crash the affected application, denying service to legitimate users. Wireshark versions 3.0.0 through 3.0.6 and 2.6.0 through 2.6.12 are vulnerable.

Technologies Affected

  • Wireshark Wireshark 2.6.0
  • Wireshark Wireshark 2.6.1
  • Wireshark Wireshark 2.6.10
  • Wireshark Wireshark 2.6.11
  • Wireshark Wireshark 2.6.12
  • Wireshark Wireshark 2.6.2
  • Wireshark Wireshark 2.6.3
  • Wireshark Wireshark 2.6.4
  • Wireshark Wireshark 2.6.5
  • Wireshark Wireshark 2.6.6
  • Wireshark Wireshark 2.6.7
  • Wireshark Wireshark 2.6.8
  • Wireshark Wireshark 2.6.9
  • Wireshark Wireshark 3.0.0
  • Wireshark Wireshark 3.0.1
  • Wireshark Wireshark 3.0.2
  • Wireshark Wireshark 3.0.3
  • Wireshark Wireshark 3.0.4
  • Wireshark Wireshark 3.0.5
  • Wireshark Wireshark 3.0.6

Recommendations

Run all software as a nonprivileged user with minimal access rights.
To reduce the impact of latent vulnerabilities, always run nonadministrative software as an unprivileged user with minimal access rights.

Deploy network intrusion detection systems to monitor network traffic for malicious activity.
Deploy NIDS to detect and block attacks and anomalous activity such as requests containing suspicious URI sequences. Since the webserver may log such requests, review its logs regularly.

Do not accept or execute files from untrusted or unknown sources.
To reduce the likelihood of successful exploits, never handle files that originate from unfamiliar or untrusted sources.

Updates are available. Please see the references or vendor advisory for more information.