PHP 'FFI::cast()' Memory Leak Denial of Service Vulnerability

2019-10-30T00:00:00
ID SMNTC-111024
Type symantec
Reporter Symantec Security Response
Modified 2019-10-30T00:00:00

Description

Description

PHP is prone to a denial-of-service vulnerability. Attackers can exploit this issue to cause a denial of service condition. Versions prior to PHP 7.4.0 are vulnerable.

Technologies Affected

  • PHP PHP 7.3.0
  • PHP PHP 7.3.1
  • PHP PHP 7.3.10
  • PHP PHP 7.3.11
  • PHP PHP 7.3.12
  • PHP PHP 7.3.2
  • PHP PHP 7.3.3
  • PHP PHP 7.3.4
  • PHP PHP 7.3.5
  • PHP PHP 7.3.6
  • PHP PHP 7.3.7
  • PHP PHP 7.3.8
  • PHP PHP 7.3.9

Recommendations

Block external access at the network boundary, unless external parties require service.
If global access isn't needed, filter access to the affected computer at the network boundary. Restricting access to only trusted computers and networks might greatly reduce the likelihood of a successful exploit.

Run all software as a nonprivileged user with minimal access rights.
To reduce the impact of latent vulnerabilities, always run nonadministrative software as an unprivileged user with minimal access rights.

Updates are available. Please see the references or vendor advisory for more information.