Asterisk Open Source CVE-2019-18976 Denial of Service Vulnerability

2019-11-21T00:00:00
ID SMNTC-110948
Type symantec
Reporter Symantec Security Response
Modified 2019-11-21T00:00:00

Description

Description

Asterisk Open Source is prone to a remote denial-of-service vulnerability. Attackers can exploit this issue to crash the application, resulting in a denial-of-service condition.

Technologies Affected

  • Asterisk Certified Asterisk 13.21
  • Asterisk Certified Asterisk 13.21-cert
  • Asterisk Certified Asterisk 13.21-cert1
  • Asterisk Certified Asterisk 13.21-cert2
  • Asterisk Certified Asterisk 13.21-cert3
  • Asterisk Certified Asterisk 13.21-cert4
  • Asterisk Open Source 13.0
  • Asterisk Open Source 13.1.0
  • Asterisk Open Source 13.10.0
  • Asterisk Open Source 13.11.0
  • Asterisk Open Source 13.12.0
  • Asterisk Open Source 13.13.0
  • Asterisk Open Source 13.13.1
  • Asterisk Open Source 13.14.0
  • Asterisk Open Source 13.14.1
  • Asterisk Open Source 13.15.0
  • Asterisk Open Source 13.16.0
  • Asterisk Open Source 13.17.0
  • Asterisk Open Source 13.17.1
  • Asterisk Open Source 13.18.0
  • Asterisk Open Source 13.18.1
  • Asterisk Open Source 13.18.2
  • Asterisk Open Source 13.18.3
  • Asterisk Open Source 13.18.4
  • Asterisk Open Source 13.18.5
  • Asterisk Open Source 13.19.0
  • Asterisk Open Source 13.19.2
  • Asterisk Open Source 13.2.0
  • Asterisk Open Source 13.20.0
  • Asterisk Open Source 13.21.0
  • Asterisk Open Source 13.21.1
  • Asterisk Open Source 13.22.0
  • Asterisk Open Source 13.23.0
  • Asterisk Open Source 13.23.1
  • Asterisk Open Source 13.24.0
  • Asterisk Open Source 13.25.0
  • Asterisk Open Source 13.26.0
  • Asterisk Open Source 13.27.0
  • Asterisk Open Source 13.27.1
  • Asterisk Open Source 13.28.1
  • Asterisk Open Source 13.3.0
  • Asterisk Open Source 13.4.0
  • Asterisk Open Source 13.5.0
  • Asterisk Open Source 13.6.0
  • Asterisk Open Source 13.7.0
  • Asterisk Open Source 13.8.0
  • Asterisk Open Source 13.9.0
  • Asterisk Open Source 16.0
  • Asterisk Open Source 16.0.0
  • Asterisk Open Source 16.0.1
  • Asterisk Open Source 16.1.0
  • Asterisk Open Source 16.2.0
  • Asterisk Open Source 16.2.1
  • Asterisk Open Source 16.3.0
  • Asterisk Open Source 16.4.0
  • Asterisk Open Source 16.4.1

Recommendations

Block external access at the network boundary, unless external parties require service.
If global access isn't needed, filter access to the affected computer at the network boundary. Restricting access to only trusted computers and networks might greatly reduce the likelihood of successful exploits.

Run all software as a nonprivileged user with minimal access rights.
To limit the potential damage that a successful exploit may achieve, run all nonadministrative software as a regular user with the least amount of privileges required to successfully operate.

Deploy network intrusion detection systems to monitor network traffic for malicious activity.
Deploy NIDS to monitor network traffic for signs of suspicious or anomalous activity. This may help detect malicious actions that an attacker may take after successfully exploiting vulnerabilities in applications. Review all applicable logs regularly.

Updates are available. Please see the references or vendor advisory for more information.