Security update for flash-player (important)

2017-03-15T21:11:54
ID SUSE-SU-2017:0703-1
Type suse
Reporter Suse
Modified 2017-03-15T21:11:54

Description

This update for flash-player fixes the following issues:

Security update to 25.0.0.127 (bsc#1029374), fixing the following vulnerabilities advised under APSB17-07: - CVE-2017-2997: This update resolves a buffer overflow vulnerability that could lead to code execution. - CVE-2017-2998, CVE-2017-2999: This update resolves memory corruption vulnerabilities that could lead to code execution. - CVE-2017-3000: This update resolves a random number generator vulnerability used for constant blinding that could lead to information disclosure. - CVE-2017-3001, CVE-2017-3002, CVE-2017-3003: This update resolves use-after-free vulnerabilities that could lead to code execution. - Details: <a rel="nofollow" href="https://helpx.adobe.com/security/products/flash-player/apsb17-07.html">https://helpx.adobe.com/security/products/flash-player/apsb17-07.html</a>