Security update for openldap2 (important)

2016-01-27T19:12:37
ID SUSE-SU-2016:0262-1
Type suse
Reporter Suse
Modified 2016-01-27T19:12:37

Description

This update fixes the following security issues:

  • CVE-2015-6908: The ber_get_next function allowed remote attackers to cause a denial of service (reachable assertion and application crash) via crafted BER data, as demonstrated by an attack against slapd. (bsc#945582)
  • CVE-2015-4000: Fix weak Diffie-Hellman size vulnerability. (bsc#937766)