Security update for Linux Kernel Live Patch 1 (important)

2015-11-24T19:14:39
ID SUSE-SU-2015:2089-1
Type suse
Reporter Suse
Modified 2015-11-24T19:14:39

Description

This kernel live patch for Linux Kernel 3.12.32-33.1 fixes two security issues:

  • CVE-2015-7613: A race condition in the IPC object implementation in the Linux kernel allowed local users to gain privileges by triggering an ipc_addid call that leads to uid and gid comparisons against uninitialized data, related to msg.c, shm.c, and util.c. (bsc#948701 bsc#948536)
  • CVE-2015-5707: Integer overflow in the sg_start_req function in drivers/scsi/sg.c in the Linux kernel allowed local users to cause a denial of service or possibly have unspecified other impact via a large iov_count value in a write request. (bsc#940342 bsc#940338)