Lucene search

K
suseSuseOPENSUSE-SU-2021:0894-1
HistoryJun 18, 2021 - 12:00 a.m.

Security update for postgresql10 (moderate)

2021-06-1800:00:00
lists.opensuse.org
19

0.007 Low

EPSS

Percentile

80.4%

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for postgresql10 fixes the following issues:

  • Upgrade to version 10.17:

  • CVE-2021-32027: Fixed integer overflows in array subscripting
    calculations (bsc#1185924).

  • CVE-2021-32028: Fixed mishandling of junk columns in INSERT … ON
    CONFLICT … UPDATE target lists (bsc#1185925).

  • Don’t use %_stop_on_removal, because it was meant to be private and got
    removed from openSUSE. %_restart_on_update is also private, but still
    supported and needed for now (bsc#1183168).

This update was imported from the SUSE:SLE-15-SP1:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

  • openSUSE Leap 15.2:

    zypper in -t patch openSUSE-2021-894=1

OSVersionArchitecturePackageVersionFilename
openSUSE Leap15.2i586< - openSUSE Leap 15.2 (i586 x86_64):- openSUSE Leap 15.2 (i586 x86_64):.i586.rpm
openSUSE Leap15.2x86_64< - openSUSE Leap 15.2 (i586 x86_64):- openSUSE Leap 15.2 (i586 x86_64):.x86_64.rpm
openSUSE Leap15.2noarch< - openSUSE Leap 15.2 (noarch):- openSUSE Leap 15.2 (noarch):.noarch.rpm