Lucene search

K
suseSuseOPENSUSE-SU-2021:0358-1
HistoryFeb 28, 2021 - 12:00 a.m.

Security update for glibc (important)

2021-02-2800:00:00
lists.opensuse.org
25

0.02 Low

EPSS

Percentile

89.0%

An update that solves 5 vulnerabilities and has one errata
is now available.

Description:

This update for glibc fixes the following issues:

  • Fix buffer overrun in EUC-KR conversion module (CVE-2019-25013,
    bsc#1182117, BZ #24973)
  • x86: Harden printf against non-normal long double values
    (CVE-2020-29573, bsc#1179721, BZ #26649)
  • gconv: Fix assertion failure in ISO-2022-JP-3 module (CVE-2021-3326,
    bsc#1181505, BZ #27256)
  • iconv: Accept redundant shift sequences in IBM1364 (CVE-2020-27618,
    bsc#1178386, BZ #26224)
  • iconv: Fix incorrect UCS4 inner loop bounds (CVE-2020-29562,
    bsc#1179694, BZ #26923)
  • Fix parsing of /sys/devices/system/cpu/online (bsc#1180038, BZ #25859)

This update was imported from the SUSE:SLE-15:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

  • openSUSE Leap 15.2:

    zypper in -t patch openSUSE-2021-358=1