Security update for rust (moderate)

2019-09-27T15:11:02
ID OPENSUSE-SU-2019:2203-1
Type suse
Reporter Suse
Modified 2019-09-27T15:11:02

Description

This update for rust fixes the following issues:

Rust was updated to version 1.36.0.

Security issues fixed:

  • CVE-2019-12083: a standard method can be overridden violating Rust's safety guarantees and causing memory unsafety (bsc#1134978)
  • CVE-2018-1000622: rustdoc loads plugins from world writable directory allowing for arbitrary code execution (bsc#1100691)

This update was imported from SUSE:SLE-15:Update.