Security update for irssi (important)

2019-01-14T00:14:11
ID OPENSUSE-SU-2019:0048-1
Type suse
Reporter Suse
Modified 2019-01-14T00:14:11

Description

An update that fixes one vulnerability is now available.

Description:

This update for irssi fixes the following issues:

  • CVE-2019-5882: Use after free when hidden lines were expired from the scroll buffer (boo#1121396)

This update to the 1.1.2 version also fixes a number of stability issues and bugs.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

  • openSUSE Leap 42.3:

    zypper in -t patch openSUSE-2019-48=1

  • openSUSE Leap 15.0:

    zypper in -t patch openSUSE-2019-48=1

  • openSUSE Backports SLE-15:

    zypper in -t patch openSUSE-2019-48=1

  • SUSE Package Hub for SUSE Linux Enterprise 12:

    zypper in -t patch openSUSE-2019-48=1