[slackware-security] php

2014-11-04T01:25:39
ID SSA-2014-307-03
Type slackware
Reporter Slackware Linux Project
Modified 2014-11-04T01:25:39

Description

New php packages are available for Slackware 14.0, 14.1, and -current to fix security issues.

Here are the details from the Slackware 14.1 ChangeLog:

patches/packages/php-5.4.34-i486-1_slack14.1.txz: Upgraded. This update fixes bugs and security issues. #68044 (Integer overflow in unserialize() (32-bits only)). (CVE-2014-3669) #68113 (Heap corruption in exif_thumbnail()). (CVE-2014-3670) #68027 (Global buffer overflow in mkgmtime() function). (CVE-2014-3668) For more information, see: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3669 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3670 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3668 ( Security fix )

Where to find the new packages:

Thanks to the friendly folks at the OSU Open Source Lab (http://osuosl.org) for donating FTP and rsync hosting to the Slackware project! :-)

Also see the "Get Slack" section on http://slackware.com for additional mirror sites near you.

Updated package for Slackware 14.0: ftp://ftp.slackware.com/pub/slackware/slackware-14.0/patches/packages/php-5.4.34-i486-1_slack14.0.txz

Updated package for Slackware x86_64 14.0: ftp://ftp.slackware.com/pub/slackware/slackware64-14.0/patches/packages/php-5.4.34-x86_64-1_slack14.0.txz

Updated package for Slackware 14.1: ftp://ftp.slackware.com/pub/slackware/slackware-14.1/patches/packages/php-5.4.34-i486-1_slack14.1.txz

Updated package for Slackware x86_64 14.1: ftp://ftp.slackware.com/pub/slackware/slackware64-14.1/patches/packages/php-5.4.34-x86_64-1_slack14.1.txz

Updated package for Slackware -current: ftp://ftp.slackware.com/pub/slackware/slackware-current/slackware/n/php-5.4.34-i486-1.txz

Updated package for Slackware x86_64 -current: ftp://ftp.slackware.com/pub/slackware/slackware64-current/slackware64/n/php-5.4.34-x86_64-1.txz

MD5 signatures:

Slackware 14.0 package: 7e7e571cc654d59f78e8c650392c7c40 php-5.4.34-i486-1_slack14.0.txz

Slackware x86_64 14.0 package: 7fa64e0f2eb45700f4fb28901634c9d0 php-5.4.34-x86_64-1_slack14.0.txz

Slackware 14.1 package: aa9822fa92fb6737b933bf6958786252 php-5.4.34-i486-1_slack14.1.txz

Slackware x86_64 14.1 package: b14ba84a31138448e3264d801900b946 php-5.4.34-x86_64-1_slack14.1.txz

Slackware -current package: 8500f42aa302e18e87b50c2106c156a4 n/php-5.4.34-i486-1.txz

Slackware x86_64 -current package: ef1909db4e6538cbd26db0fb70cf4160 n/php-5.4.34-x86_64-1.txz

Installation instructions:

Upgrade the package as root: > upgradepkg php-5.4.34-i486-1_slack14.1.txz

Then, restart Apache httpd: > /etc/rc.d/rc.httpd stop > /etc/rc.d/rc.httpd start