lha update in bin package

2004-05-04T16:34:52
ID SSA-2004-125-01
Type slackware
Reporter Slackware Linux Project
Modified 2004-05-04T16:34:52

Description

New bin- packages are available for Slackware 8.1, 9.0, 9.1, and -current to fix buffer overflows and directory traversal vulnerabilities in the 'lha' archive utility. Sites using 'lha' should upgrade to the new bin package right away.

More details about these issues may be found in the Common Vulnerabilities and Exposures (CVE) database:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0234 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0235

Here are the details from the Slackware 9.1 ChangeLog:

Tue May 4 13:11:26 PDT 2004 patches/packages/bin-8.5.0-i486-2.tgz: Fixed buffer overflows and directory traversal vulnerabilities in the 'lha' archive utility. Sites using 'lha' should upgrade to the new bin package right away. For more details, see: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0234 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0235 ( Security fix )

Where to find the new packages:

Updated package for Slackware 8.1: ftp://ftp.slackware.com/pub/slackware/slackware-8.1/patches/packages/bin-8.3.0-i386-3.tgz

Updated package for Slackware 9.0: ftp://ftp.slackware.com/pub/slackware/slackware-9.0/patches/packages/bin-8.5.0-i386-2.tgz

Updated package for Slackware 9.1: ftp://ftp.slackware.com/pub/slackware/slackware-9.1/patches/packages/bin-8.5.0-i486-2.tgz

Updated package for Slackware -current: ftp://ftp.slackware.com/pub/slackware/slackware-current/slackware/a/bin-9.0.0-i486-2.tgz

MD5 signatures:

Slackware 8.1 package: 3384ae4bc983d18ee003a8e2445b7879 bin-8.3.0-i386-3.tgz

Slackware 9.0 package: 809e3c75d913a39e886f3a38a41e36f3 bin-8.5.0-i386-2.tgz

Slackware 9.1 package: 3db010726fafe7112ff509bd6c1c2909 bin-8.5.0-i486-2.tgz

Slackware -current package: 572f9835f4e2833688482ce866a7b7d4 bin-9.0.0-i486-2.tgz

Installation instructions:

Upgrade the package as root: > upgradepkg bin-8.5.0-i486-2.tgz