Horizon QCMS 4.0 'category' 参数SQL注入漏洞

2015-10-12T00:00:00
ID SSV:89672
Type seebug
Reporter Root
Modified 2015-10-12T00:00:00

Description

受影响系统

Horizon QCMS Horizon QCMS <= 4.0

描述:


BUGTRAQ ID: 64715 CVE(CAN) ID: CVE-2013-7139

Horizon QCMS是支持PHP及MySQL的开源快速内容管理系统。

Horizon QCMS 4.0及之前版本没有正确过滤"/download.php"脚本内的"category" HTTP POST参数,在实现上存在SQL注入漏洞,远程攻击者利用此漏洞可用应用数据库内执行任意SQL命令。

<*来源:High-Tech Bridge Security Research Lab

链接:http://seclists.org/bugtraq/2014/Jan/16 *>

测试方法:


警 告

以下程序(方法)可能带有攻击性,仅供安全研究与教学之用。使用者风险自负!

http://[host]/download.php?category=%27%20union%20select%201,2,version(),4,5,6%20--%202

建议:


厂商补丁:

Horizon QCMS

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.hnqcms.com/

参考:

http://sourceforge.net/projects/hnqcms/files/patches/