VisualShapers ezContents <= 2.0.3 Authentication Bypass and Multiple SQL Injection Vulnerabilities

2014-07-01T00:00:00
ID SSV:86758
Type seebug
Reporter Root
Modified 2014-07-01T00:00:00

Description

No description provided by source.

                                        
                                            
                                                source: http://www.securityfocus.com/bid/37858/info

VisualShapers ezContents is prone to an authentication-bypass vulnerability and multiple SQL-injection vulnerabilities because it fails to sufficiently sanitize user-supplied data before using it in an SQL query.

Exploiting these issues could allow an attacker to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.

ezContents 2.0.3 is vulnerable; other versions may also be affected.

The following example data is available:

login page: admin' AND IF(@Condition,BENCHMARK(1000000, md5(10)),2) OR '1'='1