Quick Cart <= 3.1 - 'admin.php' Cross Site Scripting Vulnerability

2014-07-01T00:00:00
ID SSV:85676
Type seebug
Reporter Root
Modified 2014-07-01T00:00:00

Description

exp:

http://www.example.com/admin.php?"><script>alert(document.cookie)</script><" Quick.Cart admin.php 中没有对用户提交的数据进行过滤,从而导致xss 该漏洞仅在IE浏览器上会触发。。。

                                        
                                            
                                                source: http://www.securityfocus.com/bid/31216/info

Quick.Cart is prone to a cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied data.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Quick.Cart 3.1 is vulnerable; other versions may also be affected.

http://www.example.com/admin.php?"><script>alert(document.cookie)</script><"