FFmpeg libavformat 'psxstr.c' STR Data Heap Based Buffer Overflow Vulnerability

2014-07-01T00:00:00
ID SSV:85326
Type seebug
Reporter Root
Modified 2014-07-01T00:00:00

Description

No description provided by source.

                                        
                                            
                                                source: http://www.securityfocus.com/bid/30154/info

The 'libavformat' library from FFmpeg is prone to a remote heap-based buffer-overflow vulnerability because of insufficient boundary checks when parsing STR data.

Remote attackers can exploit this issue by enticing victims into opening maliciously crafted STR files with an application that uses the affected library.

Successful exploits may allow attackers to execute arbitrary code within the context of an affected application. Failed exploit attempts will likely result in a denial of service. 

http://www.exploit-db.com/sploits/32019.iki