Insanely Simple Blog 0.4/0.5 Blog Anonymous Blog Entry XSS

2014-07-01T00:00:00
ID SSV:83744
Type seebug
Reporter Root
Modified 2014-07-01T00:00:00

Description

No description provided by source.

                                        
                                            
                                                source: http://www.securityfocus.com/bid/24934/info
 
Insanely Simple Blog is prone to multiple input-validation vulnerabilities, including cross-site scripting, HTML-injection, and SQL-injection issues, because the application fails to properly sanitize user-supplied input.
 
Exploiting these issues could allow an attacker to steal cookie-based authentication credentials, execute arbitrary script code in the context of the webserver process, steal cookie-based authentication credentials, compromise the application, obtain sensitive information, access or modify data, or exploit latent vulnerabilities in the underlying database.
 
Insanely Simple Blog 0.5 and prior versions are vulnerable. 

<B onmousemver="javascript:alert('lol')">Pizza pie</B>
<OL onmouseover="alert('lol')">I like it</OL>