Dragonfly Commerce 1.0 - Multiple SQL Injection Vulnerabilities

2014-07-01T00:00:00
ID SSV:79614
Type seebug
Reporter Root
Modified 2014-07-01T00:00:00

Description

No description provided by source.

                                        
                                            
                                                source: http://www.securityfocus.com/bid/14220/info

Dragonfly Commerce is prone to multiple SQL injection vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input before using it in SQL queries.

Successful exploitation could result in a compromise of the application, disclosure or modification of data, or may permit an attacker to exploit vulnerabilities in the underlying database implementation.

There are conflicting reports regarding whether or not these vulnerabilities are present. The vendor has stated that the vulnerabilities do not exist. This BID will be updated as further information becomes available. 

http://www.example.com/dc_Categoriesview.asp??key='&RecPerPage=5
http://www.example.com/demo/dc_productslist_Clearance.asp?cmd=%27
http://www.example.com/demo/ratings.asp??PID='
http://www.example.com/demo/dc_forum_Postslist.asp?start='
http://www.example.com/demo/dc_forum_Postslist.asp?key_m='
http://www.example.com/demo/dc_forum_Postslist.asp?psearch=1&Submit=Search%20%28%2A%29&psearchtype='
http://www.example.com/demo/dc_forum_Postslist.asp?psearch='&Submit=Search%20%28%2A%29&psearchtype=1