phpWebsite 0.7.3/0.8.x/0.9.x Index.PHP Directory Traversal Vulnerability

2014-07-01T00:00:00
ID SSV:79596
Type seebug
Reporter Root
Modified 2014-07-01T00:00:00

Description

No description provided by source.

                                        
                                            
                                                source: http://www.securityfocus.com/bid/14166/info

phpWebSite is affected by a directory traversal vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

A remote unauthorized user can disclose the contents of arbitrary local files through the use of directory traversal strings '../'. Exploitation of this vulnerability could lead to a loss of confidentiality.

The vendor has released the patch phpwebsite_security_patch_20050705.2.tgz addressing this issue. 

http://www.example.com/phpwebsite/index.php?module=search&search_op=search&mod=../../../../../../../../etc/passwd%00&query=1&search=Search