Warrior Kings 1.3 And Warrior Kings: Battles 1.23 Remote Format String Vulnerability

2014-07-01T00:00:00
ID SSV:79348
Type seebug
Reporter Root
Modified 2014-07-01T00:00:00

Description

No description provided by source.

                                        
                                            
                                                source: http://www.securityfocus.com/bid/13711/info

Warrior Kings, and Warrior Kings: Battles are vulnerable to a remote format string vulnerability. This issue is due to a failure of the application to securely implement a formatting printing function.

This vulnerability allows remote attackers to crash affected game servers. Due to the nature of this vulnerability, it is also likely that attackers may cause arbitrary machine code to be executed in the context of the affected game server. 

http://www.exploit-db.com/sploits/25691-1.zip

http://www.exploit-db.com/sploits/25691-2.zip