ActivePerl 5.x,Larry Wall Perl 5.x Duplication Operator Integer Overflow Vulnerability

ID SSV:77866
Type seebug
Reporter Root
Modified 2014-07-01T00:00:00


No description provided by source.


ActiveState Perl is reported to be prone to an integer overflow vulnerability. It is revealed through testing that other implementations are also vulnerable.

The issue is reported to exist due to a lack of sufficient bounds checking that is performed on multiplier data that is passed to a Perl duplicator statement. This vulnerability may permit an attacker to influence execution flow of a vulnerable Perl script to ultimately execute arbitrary code. Failed exploit attempts will result in a denial of service.

$var = "ABCD"x0x40000000;