Xoops 2.0.5 .1 MyLinks Myheader.php Cross-Site Scripting Vulnerability

2014-07-01T00:00:00
ID SSV:77224
Type seebug
Reporter Root
Modified 2014-07-01T00:00:00

Description

No description provided by source.

                                        
                                            
                                                source: http://www.securityfocus.com/bid/9269/info

Xoops is prone to a cross-site scripting vulnerability in the 'myheader.php' script included in the mylinks module. A remote attacker could exploit this issue by embedding hostile HTML and script code in a malicious link to the vulnerable script. Exploitation could allow for theft of cookie-based authentication credentials or other attacks.

This issue was reported in Xoops 2.0.5.1. It is likely that other versions are also affected. 

http://www.example.com/modules/mylinks/myheader.php?url=javascript:alert(document.cookie);

http://www.example.com/modules/mylinks/myheader.php?url="><script>alert(document.cookie)</script>