MySimpleNews 1.0 PHP Injection Vulnerability

2014-07-01T00:00:00
ID SSV:75718
Type seebug
Reporter Root
Modified 2014-07-01T00:00:00

Description

No description provided by source.

                                        
                                            
                                                source: http://www.securityfocus.com/bid/5865/info

MySimpleNews allows users to enter news articles through a web interface. It will allow PHP code to be injected into URI parameters of the 'users.php' script, which will be stored into a MySimpleNews file (news.php3). The injected code may then be executed by the attacker by requesting the 'news.php3' script.

http://[target]/users.php?LOGIN=[PHP code]

http://[target]/users.php?DATA=[PHP code]

http://[target]/users.php?MESS=[PHP code]

PHP code injected in this manner can be executed with the following request:

http://[target]/news.php3