SCO Open Server 5.0.6 lpshut Buffer Overflow Vulnerability

2014-07-01T00:00:00
ID SSV:74599
Type seebug
Reporter Root
Modified 2014-07-01T00:00:00

Description

No description provided by source.

                                        
                                            
                                                source: http://www.securityfocus.com/bid/2555/info


SCO OpenServer 5.0.6 (and possibly earlier versions) ships with several suid bin executables used in printer administration and related tasks.

This includes lpshut, a component used to shut down the LP print service. 'lpshut' contains a locally exploitable bufffer overflow due to a lack of bounds checking during operations performed on user-supplied data.

An attacker may exploit this vulnerability to execute arbitrary code with effective userid 'bin' privileges. 

/opt/K/SCO/Unix/5.0.6Ga/usr/lib/lpshut `perl -e 'print "A" x 7000'`

Memory fault - core dumped