PostgreSQL远程栈缓冲区溢出漏洞

2014-02-25T00:00:00
ID SSV:61543
Type seebug
Reporter Root
Modified 2014-02-25T00:00:00

Description

BUGTRAQ ID: 65719 CVE(CAN) ID: CVE-2014-0063

PostgreSQL是一款高级对象-关系型数据库管理系统,支持扩展的SQL标准子集。

PostgreSQL 9.3.3, 9.2.7, 9.1.12, 9.0.16, 8.4.20之前版本的常数MAXDATELEN对于类型interval的最长值过小,这可使interval_out()缓冲区溢出。为避免缓冲区溢出,日期时间函数会拒绝包含了较长时间域名称的有效输入。ecpg库内包含了这些漏洞。经过身份验证的数据库用户可利用此漏洞造成PostgreSQL服务器崩溃或执行任意代码。 0 PostgreSQL PostgreSQL 8.x 厂商补丁:

PostgreSQL

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.postgresql.org