Ruby will_paginate Gem跨站脚本漏洞

2014-01-06T00:00:00
ID SSV:61281
Type seebug
Reporter Root
Modified 2014-01-06T00:00:00

Description

CVE ID:CVE-2013-6459

Ruby是跨平台、面向对象的动态类型编程语言。will_paginate是一个分页插件,提供将搜索结果进行分页显示的功能。

will_paginate gem for Ruby存在跨站脚本漏洞。远程攻击者可通过与生成的分页链接相关的输入利用该漏洞注入任意Web脚本或HTML。 0 will_paginate gem for Ruby 3.x 厂商补丁:

Ruby

厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

https://github.com/mislav/will_paginate/releases/tag/v3.0.5