Linux Kernel KVM 拒绝服务漏洞(CVE-2013-1798)

2013-03-24T00:00:00
ID SSV:60707
Type seebug
Reporter Root
Modified 2013-03-24T00:00:00

Description

BUGTRAQ ID: 58604 CVE(CAN) ID: CVE-2013-1798

Linux Kernel是Linux操作系统的内核。

如果客户端指定了带有无效值的IOAPIC_REG_SELECT,然后读取IOAPIC_REG_WINDOW,KVM就不会正确验证该请求。ioapic_read_indirect包含了ASSERT(redir_index < IOAPIC_NUM_PINS),但ASSERT在非调试build中不起作用。在最近版本中,读取无效内存会造成内核崩溃,在较早版本内,会允许客户端读取较大范围的主机内存。攻击者可利用此漏洞触发内核崩溃,拒绝服务合法用户。 0 Linux kernel 3.x Linux kernel 2.6.x 厂商补丁:

Linux

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.kernel.org/