Ruby on Rails 远程代码执行漏洞(CVE-2013-0277)

2013-03-07T00:00:00
ID SSV:60663
Type seebug
Reporter Root
Modified 2013-03-07T00:00:00

Description

BUGTRAQ ID: 57898 CVE(CAN) ID: CVE-2013-0277

Ruby on Rails简称RoR或Rails,是一个使用Ruby语言写的开源Web应用框架,它是严格按照MVC结构开发的。

Ruby on Rails 3.x、2.3.x中的活动记录允许远程攻击者通过特制的序列化属性造成拒绝服务或执行任意代码,这些特制的属性可造成+serialize+ helper反序列化任意YAML。 0 Ruby on Rails 3.2.x Ruby on Rails 3.1.x Ruby on Rails 2.3.x 厂商补丁:

Ruby on Rails

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.rubyonrails.com/