PHP 5.4.0RC2-5.4.0 'main/SAPI.c' HTTP标头注入漏洞

2012-09-18T00:00:00
ID SSV:60388
Type seebug
Reporter Root
Modified 2012-09-18T00:00:00

Description

BUGTRAQ ID: 55527 CVE ID: CVE-2012-4388

PHP是一种HTML内嵌式的语言,PHP与微软的ASP颇有几分相似,都是一种在服务器端执行的嵌入HTML文档的脚本语言,语言的风格有类似于C语言,现在被很多的网站编程人员广泛的运用。

PHP 5.4.0RC2-5.4.0版本的main/SAPI.c内sapi_header_op函数在检查%0D序列时没有正确确定指针,可允许远程攻击者通过特制的URL绕过HTTP响应分离保护机制,该URL相关PHP标头函数和某些浏览器直接的不恰当交互。 0 PHP 5.4.0RC2-5.4.0 厂商补丁:

PHP

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.php.net