IPsec-Tools多个远程拒绝服务漏洞

2008-12-05T00:00:00
ID SSV:4522
Type seebug
Reporter Root
Modified 2008-12-05T00:00:00

Description

BUGTRAQ ID: 30657 CVE(CAN) ID: CVE-2008-3651,CVE-2008-3652

IPsec-Tools是KAME的IPsec工具到Linux平台上的移植。

ipsec-tools的racoon守护进程的src/racoon/handler.c文件没有删除远程初始化的孤儿ph1句柄,racoon/proposal.c文件中存在内存泄露漏洞。如果远程攻击者发送了无效请求报文的话,就可能导致耗尽所有可用内存。

IPsec-Tools < 0.7.1 RedHat


RedHat已经为此发布了一个安全公告(RHSA-2008:0849-01)以及相应补丁: RHSA-2008:0849-01:Important: ipsec-tools security update 链接:<a href=https://www.redhat.com/support/errata/RHSA-2008-0849.html target=_blank>https://www.redhat.com/support/errata/RHSA-2008-0849.html</a>

Gentoo

Gentoo已经为此发布了一个安全公告(GLSA-200812-03)以及相应补丁: GLSA-200812-03:IPsec-Tools: racoon Denial of Service 链接:<a href=http://security.gentoo.org/glsa/glsa-200812-03.xml target=_blank>http://security.gentoo.org/glsa/glsa-200812-03.xml</a>

所有IPsec-Tools用户都应升级到最新版本:

# emerge --sync
# emerge --ask --oneshot -v &quot;&gt;=net-firewall/ipsec-tools-0.7.1&quot;