phpMyAdmin PMA_escapeJsString()跨站脚本漏洞

2008-09-25T00:00:00
ID SSV:4091
Type seebug
Reporter Root
Modified 2008-09-25T00:00:00

Description

BUGTRAQ ID: 31327

phpMyAdmin是用PHP编写的工具,用于通过WEB管理MySQL。

phpMyAdmin的libraries/js_escape.lib.php文件中的PMA_escapeJsString()函数存在跨站脚本漏洞。如果用户受骗访问了恶意网页的话,远程攻击者就可以绕过某些过滤器,在用户浏览器会话中执行任意HTML和脚本代码。

phpMyAdmin < 2.11.9.2 phpMyAdmin


目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

<a href=http://www.phpmyadmin.net/home_page/downloads.php?relnotes=1 target=_blank>http://www.phpmyadmin.net/home_page/downloads.php?relnotes=1</a>