Zen Cart SQL注入漏洞

2008-09-10T00:00:00
ID SSV:3989
Type seebug
Reporter Root
Modified 2008-09-10T00:00:00

Description

BUGTRAQ ID: 31023 CNCAN ID:CNCAN-2008090509

Zen Cart是一款基于PHP的WEB应用程序。 Zen Cart不正确处理用户提交的输入,远程攻击者可以利用漏洞进行SQL注入攻击,可能获得敏感信息或操作数据库。 问题由于脚本对用户提交给WEB参数缺少过滤,构建恶意SQL查询作为参数数据,可更改原来的SQL逻辑,获得敏感信息或操作数据库。

Zen Cart Web Shopping Cart 1.3.8 Zen Cart Web Shopping Cart 1.3.7 Zen Cart Web Shopping Cart 1.3.6 Zen Cart Web Shopping Cart 1.3.5 Zen Cart Web Shopping Cart 1.3.2 Zen Cart Web Shopping Cart 1.3 Zen Cart Web Shopping Cart 1.2.7 Zen Cart Web Shopping Cart 1.2.6 d Zen Cart Web Shopping Cart 1.2 Zen Cart Web Shopping Cart 1.3.8a 可参考如下供应商提供的补丁: <a href=http://www.zen-cart.com/forum/showthread.php?p=604473 target=_blank>http://www.zen-cart.com/forum/showthread.php?p=604473</a>